
EE 541 – Automated Layout of Integrated Systems 
Program #1: Introduction to Aphyds and Java 

In this assignment, you will learn Java and the basics of the Aphyds toolsuite, and demonstrate your mastery on a 
simple program.  Your code will compute the delay at each node of a circuit graph, allowing you to determine the 
critical path of a circuit. 

Supported Machines 

The directions in the class assume you are using a PC, either your own laptop or one of the machines in 
the EE computer labs.  If you want to use a different machine, that is fine – everything is in Java, which is 
portable.  HOWEVER, the initial setup may take you a while, since configuring the debugger for some 
steps is a bit involved, and the Professor has not test-driven these steps for you. 

If you are going to use anything other than a Windows PC, start early on the first assignment! 

Aphyds 

All of the programming assignments for this class are done within Aphyds (Academic PHYsical Design Suite), 
written by Prof. Scott Hauck (yep, that’s me!).  This is a fairly complete skeleton for laying out standard cell 
designs.  It handles all file I/O, windowing, most data structures, lots of error checking, and many other issues.  To 
complete your assignments you will be able to focus almost entirely on the “good stuff”, the parts of the code that 
represent real understanding of the CAD algorithms, and leave the rest to the skeleton.  Hopefully, this will reduce 
the complexity of each programming assignment by a factor of 5-10 (20 hours to 4 hours for example).  Also, I have 
written a solution to each programming assignment within this framework, so I know that all the assignments are 
reasonable and solvable. 

Over the course of this quarter you will write:  
 1. Delay computation (simple, designed to help you learn Java and the basics of Aphyds) . 
 2. Fiduccia-Mattheyses partitioner.  
 3. Slicing-tree based hierarchical floorplanner.  
 4. Simulated annealing placer.  
 5. Maze global router.  
 6. Left-edge algorithm channel/detailed router. 

Anyone wishing to go it alone, and code up their own system from scratch, is welcome to do so – it’s probably only 
~11,000 lines of Java… 

You can get your copy of the Aphyds source code, ready for your editing, from the web-page.  The source code is in 
“zip” compression format.  On windows right-click and select “Extract All…” – on other OSes unzip it by typing 
“unzip aphyds” or find an appropriate utility.  Finally, there is a fully-functional version of Aphyds you can play 
with (and compare with your results) at “aphydsRelease.jar”.  Note that for some algorithms your results should be 
exactly the same, but for others they may be different.  This depends on whether the algorithm is deterministic or 
not. 

Installing & Using Java 

Java is a very portable language – Java code that runs on one machine will, in most cases, run on any other Java 
machine.  This means that you can use whatever machine you prefer to develop your code.  For directions on 
installing and using Java, Oracle has a tutorial at: 

 http://docs.oracle.com/javase/tutorial/ 



Read “Getting Started”, which will explain how to get started.  For code development I suggest using Eclipse.  This 
is a full-featured, open-source development system for Java.  To use Eclipse, there are two major steps: 

1.) Install the Java SE Development Kit (JDK).  Go to the Java SE download page 
http://www.oracle.com/technetwork/java/javase/downloads/index.html and install the JDK (near top of 
page).  This supports most platforms. 

2.) Install Eclipse IDE for Java Developers.  Go to www.eclipse.org , click download (oxygen is the name of 
the current release), and follow the directions to install the “Eclipse IDE for Java Developers”. 

Once you get Eclipse installed, you should configure it.  Make sure you have the Aphyds sourcecode downloaded 
and unzipped on your machine.  Start up eclipse, and use the default workspace.  Then, create a new project (File-
>New->Java Project).  Give it the name “Aphyds” and hit “finish”.  You will now need to get the aphyds 
sourcecode.  Go to File->Import, and select “General->File System”, and hit next.  Under “From directory” browse 
for the directory where you put the Aphyds sourcecode from the java .zip file you got from the website, and select 
the “src” subdirectory.  You should “select all” to select all the files in that directory.  The “into folder” should be 
“Aphyds/src”.  Hitting “finish” will then import all the files into your Aphyds project. 

You should now go to the workbench and run the project.  First, open the file “CircuitViewer.java” from the default 
package in the src directory.  Then, you can just hit the green arrow on the toolbar, or do “Run->Run”.  Subsequent 
runs with Eclipse and Aphyds will not require all of these steps – just start up Eclipse and hit run. 

Running the complete Aphyds from the .jar file 

To help in your development and testing of your own algorithms, I have provided a completed version of the 
system.  Go to the class website and download the “working Aphyds system”.  Then uncompress that directory.  In 
the uncompressed directory is a file “aphydsRelease.jar”, which is a protected, compiled version of the working 
system. 

Starting the complete version the first time is a bit annoying, but after that it will be fairly simple.  First, find out 
where java.exe is on your machine by using the file explorer to look around.  For me it is at: 

C:\Program Files\Java\jre1.8.0_144\bin\java.exe 

Yours will likely be similar, though the “C” drive might be a different one, and the numbers after jre are the release 
you grabbed, which might be slightly different. 

Start Eclipse.  Select “Run>External Tools>External Tools Configurations…”.  Select Program, right-click, and 
select “new”.  Fill in the following entries: 

 Name: AphydsComplete 

 Location: <java executable path and name.  For me it is: C:\Program Files\Java\jre1.8.0_144\bin\java.exe> 

 Working directory: <where the .jar file is.  For me it is: C:\Users\Scott\Desktop\AphydsComplete17> 

 Arguments: -Xverify:none -cp .\aphydsRelease.jar CircuitViewer 

Hit “Run”, and the program will start up.  Also, the configuration is now saved.  So, in future you can click 
“Run>External Tools>AphydsComplete”. 

Learning Java 

In this class we use Java for its portability and easy support of graphics and windows.  It also is a simpler language 
to use than C/C++, and completely avoids many standard pitfalls from those languages.  All in all, I think you will 



like the language.  The best thing is that, by knowing C/C++, you already know about 90% of the concepts, even the 
syntax, you will need in Java.  As you will see, most simple Java code is identical (or at least very close) to its C or 
C++ counterparts. 

For all of the assignments in this class you will only need to learn a small subset of the Java language.  However, for 
those of you considering a career involving programming, this might be a good time to learn Java as a whole.  An 
excellent book on Java is David Flanagan’s Java in a Nutshell from publisher O’Reilly 

For those of you preferring a free way to learn the basics of Java, Oracle maintains a tutorial at:  
 http://docs.oracle.com/javase/tutorial/ 
You should read the following trails:  
 Getting Started (skim)  
 Learning the Java Language  
 Essential Java Classes (skim) 

Along either path you will get the information you need to complete your assignments.  Don’t worry too much if 
there are concepts you do not get the first time.  Come back to them when you need them, since most of the harder 
concepts you won’t need to use at all. 

Another useful link on the web, no matter how you learn and use Java, is the API.  This is a site having help files on 
almost all of the features of Java:  
 http://download.oracle.com/javase/8/docs/api/ 

You can look up most classes here.  For example, “Enumeration” and “Vector” will be important to understand, and 
this site has good explanations of these and other classes.  Keep a web browser open to this site as you code up your 
applications. 

Important Java Idioms 

There are several features of Java that are very useful, but which you might miss the first time you read about the 
language: 

Signaling errors 

As you write your code, you will often want to signal errors to the user.  For example, your routine might assume 
that a given number is always positive.  You should always check these conditions, and signal an error if your 
assumptions are violated.  This will help you debug your programs more quickly, since you’ll signal an error at the 
first hint of trouble. 

In Java, you “throw” an error.  Other routines in the Aphyds code will “catch” these errors, printing out the state of 
the program when the error occurred (the “call stack”) and display an error message in a dialog box.  An example of 
the throw portion of this code would be: 

if (PositiveVariable <= 0) 
 throw (new Error("PositiveVariable should be greater than 0, but was: “ 
        + String.valueOf(PositiveVariable))); 

The ”throw” signals the error, while the “new Error(string)” captures the state of the program, and adds a 
descriptive message for display. 

Printing messages 

Often you want to print messages to the user.  There are fancy ways to do this with dialog boxes and such, but most 
of the time you’ll just want to print simple status information and the like.  To do this, use 
“System.out.println(string)”.  Note that this buffers the output, grouping together messages to make the printing 



more efficient.  When you are debugging, this is a pain.  To have a way to say “print it NOW!”, you should call 
“System.out.flush()”, which will print out all pending messages before continuing.  Also, “System.out.print” is the 
same as println, except it doesn’t automatically add a newline at the end. 

Here is a sample of code that does this: 

System.out.println("Starting Cutsize: " + String.valueOf(oldcutsize) 
   + ", Maximum partition size: " + String.valueOf(max_size)); System.out.flush(); 

This code prints out a message composed of some text strings, along with the value of some variables.  This is the 
equivalent of printf() from C/C++. 

Javadoc 

Javadoc is a program which takes in Java code, and converts specially designed comments into HTML help files 
(for viewing and navigating in a web browser).  It organizes these in a reasonable way, and provides linking 
between related pieces of code.  It also hides the details of the code that aren’t important to most readers.  You’ll 
find that the first thing you want to do whenever you see new Java code is to read the .html files for it. 

Most of the instructions for your homework assignments will be found in Javadoc code, along with information on 
the routines you will need.  Also, if it doesn’t appear in Javadoc, it isn’t important for you to understand that 
part of the code.  Some methods and variables have been assigned “private” or “package” visibility specifically to 
hide unimportant details from you.  Conversely, those elements you should know about have been assigned 
“protected” or “public” visibility to allow you to see them in Javadoc.  This isn’t quite standard Java usage, but is 
appropriate to help you quickly understand the code. 

You can see the Javadoc for all the classes within eclipse.  In the package explorer (lefthand side of eclipse) go to 
Aphyds>src>api. 

Programming assignment 

The top level of the program is called “CircuitViewer.java”.  Compiling this program and executing it in the 
interpreter will run the program, along with whatever modifications you have made.  The first thing you should do 
is open a file (file->open or CNTRL-O).  Then, the edit menu will give access to all of the individual CAD 
algorithms. 

Once a file is loaded, notice that clicking on a node brings up the node dialog box, displaying information about that 
node (including the path delay, which you will compute during this assignment).  Clicking on an input or output 
brings up the net dialog, giving information about the nets.  Similarly, clicking on a source or destination on the net 
dialog changes the node dialog to point to that node.  This will allow you to examine the circuit, and understand its 
structure. 

Your task is to implement the “Compute Path Delays” module for this system, which is invoked from the “Edit” 
menu.  To do so, use javadoc to create documentation for the files in this system, and then use a web browser to 
show the file Circuit.html.  Your assignment will be to implement the function ComputePathDelays() within 
Circuit.java.  The file Circuit.html will have all the information necessary for this, including hyperlinks to other data 
structures and methods you will need to use in developing this code.  An understanding of the main methods of 
Circuit.java, Net.java, and Node.java will be useful.  In almost all cases, you will simply refer to the corresponding 
javadoc-created .html files for each of these routines to help you learn the code. 

Your code will go through the circuit, computing the path delay to each node.  A path delay is composed of the 
intrinsic delays of the nets and nodes it passes through, with each node’s path delay equal to the worst-case (largest) 
delay along all paths leading to this node.  An easy way to compute the path delay at a node is to compute the path 
delay to all of the nodes that produce this node’s input(s).  Then, the delay of this node X is the maximum of the 



path delay at each input source node N, plus the intrinsic delay of N, plus the intrinsic delay of the net connecting N 
to the node X in question. 

For example, consider file inverter.circ.  It has an INPUT In1, connected to an INVERTER Negator, connected to 
an OUTPUT Pin34.  All nets are 1 output, so they have a delay of 0.75ns.  The inverter has less than 3 inputs, so it 
has a delay of 1.0ns.  All INPUT and OUTPUT nodes have a delay of 0.0ns. 

In1 is an input, so its path delay is 0.0ns.  To get to Negator, we go through the INPUT node (0.0ns) and Sig39 
(0.75ns), for a path delay at Negator of 0.75ns.  To get to the OUTPUT pad we go through the INVERTER (1.0ns), 
and through signal NotQuiteSig39 (0.75ns), for a path delay at OUTPUT Pin34 of 2.5ns.  Since this is the longest 
path, the critical path for this circuit is 2.5ns.  Note that if the inverter was replaced by a 2-input gate, you would 
compute the delay of the node due to each of its inputs separately, and then choose the largest of the delay numbers. 

Toggle.circ is also a good development test case for this problem, since it has a simple DFF-based circuit.  DFF’s 
tend to be tricky, since they are both the beginning and the end of cycles.  FOR THIS PROBLEM, THE DELAY 
OF A DFF CAN OCCUR ON THE BEGINNING OF A PATH, BUT NOT THE END.  This is important for 
situations where the critical path either begins or ends on a DFF, but not both.  For example, if the circuit is a DFF 
by itself, the path delays in the circuit are (1) The delay of the wire hooked to the DFF’s D input; (2) The delay the 
DFF + the delay of the wire hooked to the DFF’s Q output; (3) The delay of each clock net individually.  Careful 
reading of the ComputePathDelays comments will also clarify this issue.  BY FAR, the most errors that occur in 
code for this problem are in DFF handling. 

This programming assignment will require understanding the public and protected functions (those that appear in 
the .html files from Javadoc) for Circuit.java, Node.java, Net.java, and perhaps Terminal.java and 
EnumerateFanout.java.  You should only need to actually modify ComputePathDelays(). 

Turnin Process 

Each of your programming assignments will involve altering a single file.  Once you complete the file, make sure it 
prints out your name when it runs (there’s a line in each file for doing this).  Then, send the following to the class 
turn-in email address (announced in class): 

1.) An estimate of the amount of hours spent on this homework (not used for grading, but just for my 
information). 

2.) The file as an attachment. 

All assignments are due by 5pm on the specified due date (see the website). 


